Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » apex report error: ORA-01403: no data found (oracle xe 10g, apex 2.1, ubuntu lucid)
apex report error: ORA-01403: no data found [message #508989] Wed, 25 May 2011 08:54 Go to next message
wucis
Messages: 60
Registered: March 2005
Member
Hello,

I added a column to a table, where I have an SQL-report from of the form SELECT * FROM MYTABLE.

Now I get the error ORA-01403: no data found.
I know that I have to go to the report definition and just press the button to apply changes.

Is there another solution ? Cause I have done this as the developer of the application. What about normal users ?
I think this is a browser cache problem but do not know how to solve it.

Even if I apply the changes to a reports sql-definition as developer, and then restart browser and login to the application as "normal apex user" the error ORA-01403: no data found appears.



Thx in advance

[Updated on: Wed, 25 May 2011 09:47]

Report message to a moderator

Re: apex report error: ORA-01403: no data found [message #509074 is a reply to message #508989] Wed, 25 May 2011 16:55 Go to previous messageGo to next message
Littlefoot
Messages: 21561
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Adding a column has nothing to do with NO DATA FOUND. I suspect that something else is raising the error, not report's query.

(Also, not related to a problem, but worth to mention: "SELECT * " is considered to be a poor programming technique. Take your time and name all columns, one by one: "SELECT id, first_name, last_name, whatever FROM MY_TABLE").
Re: apex report error: ORA-01403: no data found [message #509088 is a reply to message #509074] Thu, 26 May 2011 00:09 Go to previous messageGo to next message
c_stenersen
Messages: 255
Registered: August 2007
Senior Member
Quote:
Adding a column has nothing to do with NO DATA FOUND


Not normally, no. But I can confirm that in this case I experience the same behavior in an ApEx report with "select *" when I add a column to the table. So ApEx is doing something in the background when showing this report which would raise this error.

But when you do the apply changes as OP describes the error disappears. You doing this as the developer should change the report for all users. I was not here able to see any difference for me as a developer and as a normal user when doing a small test case.
Re: apex report error: ORA-01403: no data found [message #509256 is a reply to message #509088] Thu, 26 May 2011 11:56 Go to previous message
Littlefoot
Messages: 21561
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
It appears that I was very wrong. I apologize.
Previous Topic: Passing date parameter into anomynous pl/sql block in APEX
Next Topic: Generating Scheduler for Some Procedures
Goto Forum:
  


Current Time: Wed May 27 05:25:16 CDT 2020