Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » Pagination Error when filtering in an Interactive Report
Pagination Error when filtering in an Interactive Report [message #529428] Mon, 31 October 2011 17:43 Go to next message
mr_hotshot_818
Messages: 25
Registered: October 2009
Junior Member

Hi All,

I'm getting a pagination error, when filtering from the column header in an Interactive Report.

Report error:

/forum/fa/9518/0/


The steps to recreate:

1. Run an Interactive Report

2. Click the next button to go to the second page of data.

3. From the column header select a data element that will return less than 15 rows. Note -- if the there are 15 or more rows of data, the error will not occur.

The Report will fail with the error shown above.



It looks like the pagination needs to be reset after the column filter, but how is this done?

I'm using the canned interactive report with no customizations. Is there a fix for this issue?



Thanks

[Updated on: Mon, 31 October 2011 17:57]

Report message to a moderator

Re: Pagination Error when filtering in an Interactive Report [message #529464 is a reply to message #529428] Tue, 01 November 2011 04:42 Go to previous messageGo to next message
Littlefoot
Messages: 21561
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Click the "Reset pagination" link on the report (yes, the one you see on the screenshot, bottom line, printed in blue color). Though, I noticed that *sometimes* it won't do anything (so I just exit and enter the report again).
Re: Pagination Error when filtering in an Interactive Report [message #529506 is a reply to message #529464] Tue, 01 November 2011 10:13 Go to previous messageGo to next message
mr_hotshot_818
Messages: 25
Registered: October 2009
Junior Member

Thanks. But my question is how do you prevent this? How do you prevent the need for the user to click the "Reset pagination" link on the report. Sorry for not being more clear.
Re: Pagination Error when filtering in an Interactive Report [message #529532 is a reply to message #529506] Tue, 01 November 2011 12:55 Go to previous messageGo to next message
Littlefoot
Messages: 21561
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I see; well, try to create a branch (make it the first branch - i.e. let its sequence be the lowest among all branches you have on that page), its target should be a page in this application (obviously, the same page, should branch to itself). Check its "reset pagination for this page" property. Try again.
Re: Pagination Error when filtering in an Interactive Report [message #529695 is a reply to message #529532] Wed, 02 November 2011 09:45 Go to previous message
mr_hotshot_818
Messages: 25
Registered: October 2009
Junior Member

This appears to be a bug in the Column filtering. When I follow the same steps, using the Filter in the Action Menu the page loads without a problem.
Previous Topic: Linking Pages in Interactive Report
Next Topic: Report Query displays no data
Goto Forum:
  


Current Time: Wed May 27 05:28:35 CDT 2020