Home » SQL & PL/SQL » Client Tools » TOAD Not Finding Oracle 11g Client (TOAD 10.6, Oracle 11g 64-bit)
TOAD Not Finding Oracle 11g Client [message #589147] Tue, 02 July 2013 14:37 Go to next message
Messages: 1
Registered: July 2013
Junior Member

I am a total newbie to Oracle and TOAD, so I hope people don't roll their eyes at my question. I have searched all over for an answer, but I have not been able to find anything that works.

I am running TOAD 10.6 on Windows 7 (64-bit). I have two 64-bit Oracle 11g clients installed (all on the same machine). The first is Instant Client (client_1); the second is the Runtime client (client_2). The installation of Instant Client was a mistake, since it doesn't have a Network / Admin folder to drop a tnsnames.ora file into. The Runtime client is my desired client, which has the aforementioned folder that I subsequently dropped the file into.

On starting TOAD, it says that "No valid Oracle Client found. Please note that Toad only supports 32 bit Oracle Client installations". (This is odd, since my colleague is running the same Oracle Runtime client as me and has TOAD 11.6, and yet his is working fine. But, this is aside the point.) When, I click on the ellipsis button next to the "Connecting Using" field, TOAD says that I don't have any Oracle homes installed. I checked my registry key (via regedit) under Computer / HKEY_LOCAL_MACHINE / SOFTWARE / ORACLE. It looks like I have 2 Oracle homes (because of the 2 clients).

Also, I right-clicked on My Computer and brought up Properties, Advanced system settings, Environment Variables (on the Advanced tab). My PATH variable has both of my clients.

Does anybody know how to make my available clients (particularly, my client_2) show up in TOAD?

Here is what I have tried thus far:
-Alter the PATH variable to just have client_2. This didn't do anything.
-Try to uninstall client_1 and client_2 via:
a) There is a Universal Installer under Oracle Installation Products in my Runtime client. I do Deinstall Products, click on any of my Oracle homes, click on Remove, and a Warning window pops up saying to run a command at some location, but the location is truncated since I can't expand the window. (I don't know what command it is talking about.)
b) In my client_2, there is a deinstall Windows Batch File in the deinstall folder. When I run this, the command window sits there for a little bit, saying that some files were copied and that 1 directory was removed. It then closes on its own. This doesn't seem to do anything.

Thanks in advance!
Re: TOAD Not Finding Oracle 11g Client [message #589148 is a reply to message #589147] Tue, 02 July 2013 15:38 Go to previous message
Messages: 21689
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
TOAD 11 is the first one that works OK with 64-bit Oracle Client (that's why your colleague runs it successfully, as he uses TOAD 11.6). You should download and install Oracle Client 32-bit in order to make your TOAD 10 work.

As of "no folder to put TNSNAMES.ORA file into", that's irrelevant. You can put TNSNAMES.ORA anywhere on your computer (for example, I created "C:\0_oracle_library" directory and have all my Oracle-related files in there, which includes TNSNAMES.ORA). What you have to do next is to create the TNS_ADMIN environment variable which will point to that directory (in my example, it points to C:\0_oracle_library). Doing so, Oracle (and TOAD) will know where to look at.
TNS_ADMIN=C:\0_oracle_library            --> here!


Finally, if you haven't install TOAD into a directory that doesn't contain any spaces (for example, C:\Quest\TOAD), do so - I didn't manage to make it work if installed elsewhere (by default, it goes to C:\Program Files (x86)\)

[Updated on: Tue, 02 July 2013 15:39]

Report message to a moderator

Previous Topic: How to migrate data from sql server to oracle data base?
Next Topic: Issue with SPOOL and decimal datatypes
Goto Forum:

Current Time: Wed Oct 27 14:47:13 CDT 2021