Home » Developer & Programmer » Reports & Discoverer » Unable to see 2nd and 3rd pages on the report (Oracle Reports:Report Builder 11.1.2.2.0; Database:11.2.0.1.0; O/S: Windowns 7 64 bit)
Unable to see 2nd and 3rd pages on the report [message #631255] Sun, 11 January 2015 16:19 Go to next message
buggleboy007
Messages: 261
Registered: November 2010
Location: Canada
Senior Member
Hi - I am facing an issue while developing a simple report. This report is based on a table called PROD.
DDL statement of PROD is:

  CREATE TABLE PROD 
       (PID VARCHAR2(6), 
	PNAME VARCHAR2(6), 
	PCOST NUMBER(4,2), 
	PPROFIT NUMBER(3,0), 
	 CONSTRAINT PROD_PK PRIMARY KEY (PID)
    );


Table gets created. Now importing data into the table.
DML statement is:
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I4','SHARPR',10,1);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I5','RULER',15,10);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I6','ERASER',5,3);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I7','STAPLR',50,20);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I8','STPPIN',10,2);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I9','FILES',99,20);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I10','CALC',99,null);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I11','CD',99,90);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I12','COUPON',99,null);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I13','PHONE',60,30);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I14','AIRTME',99,90);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I3','PEN',20.5,20);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I2','FLOPPY',30,12);
Insert into PROD (PID,PNAME,PCOST,PPROFIT) values ('I1','PENCIL',5.25,null);
 
COMMIT;
/


Data gets committed.

Now I design a report based on the above. The report contains a main frame called M_1. This is just an enclosure to keep repeating frame and fields under M_1.
A repeating frame is also created. When the repeating frame is created, the property "Max records per page" is set to "5" such that I can display above 14 records into 3 pages.
I compile it and it compiles successfully. However when I run the report I only see 5 records on 1st page. The remaining pages do not appear at all. Do you think I am doing anything wrong here?

I have attached the report(EX10_3.rdf) as well in my post. Can any one point me in the right direction?
  • Attachment: EX10_3.rdf
    (Size: 40.00KB, Downloaded 305 times)
Re: Unable to see 2nd and 3rd pages on the report [message #631262 is a reply to message #631255] Mon, 12 January 2015 01:39 Go to previous message
Littlefoot
Messages: 21610
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you create that report using Wizard? If not, perhaps you should have - it does everything right. If you do it manually, there are good chances to screw something up.

Anyway: M_1 and R_1 frames' "Print Object On" property should be set to "First page".
Previous Topic: count sundays
Next Topic: getting different laguage output in reports
Goto Forum:
  


Current Time: Thu Oct 22 02:15:32 CDT 2020