Home » Developer & Programmer » Reports & Discoverer » printer formatting not work (Oracle Reports 11.2.0, Windows 2012 R2)
icon5.gif  printer formatting not work [message #650577] Wed, 27 April 2016 21:23 Go to next message
terminals
Messages: 2
Registered: April 2016
Junior Member
I'm setting up Oracle Reports on Win 2012. When using rwservlet and directly print to printer (destype=printer), the output is always no formatting (landscape, line size=80). I am already using desformat=wide180.prt but no effect.

But, if I let Oracle to generate a report file and then send the file directly to the same printer using "type" command, the output format is working properly. Could any experts here advise why? Is it related to confg in Reports or OS? Thanks for your help!

Below is the related info:

Oracle Reports prints to printer:
http://hostname.xxx.com:9002/reports/rwservlet?server=RptSvr_asinst_1+destype=printer+desformat=C:\oracle\Middleware\Oracle_FRHome1\r eports\printers\wide180.prt+report=D:\report\report123.rdf+desname=myprintq+userid=scott/tiger@db+input_date=01012016

Generate file:
http://hostname.xxx.com:9002/reports/rwservlet?server=RptSvr_asinst_1+destype=file+desformat=C:\oracle\Middleware\Oracle_FRHome1\repo rts\printers\wide180.prt+report=D:\report\report123.rdf+desname=c:\temp\report123.txt+userid=scott/tiger@db+input_date=01012016

Step to send file to printer:
1. share the printer
2. map the printer to lpt2:
> net use lpt2: \\ip\printername

3. send to printer
> type report123.txt > lpt2:

[Updated on: Wed, 27 April 2016 21:56]

Report message to a moderator

Re: printer formatting not work [message #650708 is a reply to message #650577] Sat, 30 April 2016 11:44 Go to previous message
terminals
Messages: 2
Registered: April 2016
Junior Member
Some more information: this same setting has been working fine on Win 2003. But now encountered this problem in win 2012.

Simply speaking,
Case 1: Report server > printer > output formatting not okay
Case 2: Report server > local file > "Type" to printer > output formatting okay
 
Now the problem is why Case 1 is not working.  Anyone have any ideas?  Thanks!
Previous Topic: Arabic Report In Adobe PDF printer
Next Topic: Customized report is errored out after R12 upgrade
Goto Forum:
  


Current Time: Fri Oct 23 06:46:05 CDT 2020