Home » Server Options » Text & interMedia » Search within an arabic/urdu document using Oracle Text.
Search within an arabic/urdu document using Oracle Text. [message #121620] Tue, 31 May 2005 02:37 Go to next message
Messages: 1
Registered: May 2005
Junior Member

I want to perform search in a word document stored in a blob.

First I tried to use the basic_lexer as shown below. It worked when I provided small search word. But failed when I provided long line of text.

ctx_ddl.create_preference('doc_lexer', 'BASIC_LEXER');
ctx_ddl.set_attribute('doc_lexer', 'printjoins', '_-');

create index idxContentMgmtBinary on CMDEMO.CONTENT_INVENTORY(TEXT) indextype is ctxsys.context
parameters ('lexer doc_lexer sync (on commit)');

Then I tried world_lexer and multi_lexer but could not succeed.

Can anyone help me performing search in arabic/urdu documents using Oracle Text?

Thanks and regards,

Re: Search within an arabic/urdu document using Oracle Text. [message #122871 is a reply to message #121620] Wed, 08 June 2005 17:51 Go to previous message
Messages: 25
Registered: April 2005
Junior Member
Can you post a little more about the issue you are running into? The following would help:

* You mentioned a long string failed. What message did you get back?
* What string failed and what string succeeded?
* Do all search strings of that length fail, or is the failure specific to a term or type of character?
* Is your string being parsed before being passed to CONTAINS? If so, post the code that is parsing it.
* What types of docs are you storing?
* Where any errors generated during indexing?

An example would certainly help as well if you can work one up.

Previous Topic: Greek themes
Next Topic: How to Retrive Clob fields Faster
Goto Forum:

Current Time: Sun Aug 14 15:51:31 CDT 2022